Wineskin.app doesn’t open, even if osu! does / exec[number].bat problem


Behaviour

When attempting to open the Wineskin.app application located inside your osu! wrapper, you receive a warning that looks similar the following message:

Error while writting file: The folder “exec2088858072.bat” doesn’t exist.

The number preceding .bat might be different for different people.


Cause

On 12 October 2020 an update was pushed to osu!macOS Agent which had a bug that while repairing a wrapper, would only repair the executable, and not the Wineskin.app settings application inside it. This was fixed on 23 January 2021.

If you downloaded osu!macOS Agent between 12 October 2020 and 23 January 2021 please download the latest version.

If the above doesn’t apply to you, other causes may include:

  • You haven’t ran the repair tool on your osu! wrapper yet

  • You have a corrupted installation

  • You used the in-built Archive Utility instead of The Unarchiver which carries some known issues

  • Your anti-virus is removing files from your osu! wrapper without your knowledge


Resolution

Warning

On 12 October 2020 an update issued for osu!macOS Agent caused Wineskin.app to display this error. See Cause. You’ll need to download the newest version of osu!macOS Agent.

  1. If you haven’t already, run the osu!macOS Agent repair tool on your osu! wrapper by following these instructions:

    • Open osu!macOS Agent

    • Go to the Troubleshoot tab

    • Click Scan

    • Click Repair

You still need to do this step on your osu! wrapper, even if osu! itself runs fine.

  1. Make sure your antivirus isn’t removing anything. Guidelines on how to do this are available here.

  2. Use The Unarchiver instead of your in-built Archive Utility.

If you tried all of that and Wineskin.app still won’t open, you can try replacing Wineskin.app with a known working version.

  1. Download the Wineskin.app replacement from https://minhaskamal.github.io/DownGit/#/home?url=https://github.com/aidswidjaja/osu-mac/tree/main/src/wineskin or https://drive.google.com/drive/folders/1Gz5Y0M4WoMxTTwb5aHUccebO5AlVm3SN?usp=sharing

    • If using Google Drive, click DOWNLOAD ALL in the top-right corner of the screen

  2. The file will download this as a zip file. Extract the zip file until you just have the Wineskin.app file

  3. Inside osu!.app (Right click > Show Package Contents) locate Wineskin.app - make a backup of it (you can just rename it to say something like Wineskin.app.backup if you want)

  4. Replace the old Wineskin.app with the replacement version you downloaded from Google Drive

Try and open it and see if everything works out.

Warning

This is an experimental hotfix. Make sure you make a backup of your Wineskin.app before replacing it with this replacement version.


If that didn’t work

There could be something else going on here, and performing basic troubleshooting should help you get to the bottom of it.

If you’re still not sure what’s going on here, copy any osu! crash logs and generate a report with osu!macOS Agent, then let us know on the forums with what we can help.